Android 2.3.5 supplicants failing after upgrade to FreeRADIUS 2.2.5 from 2.2.0

Fajar A. Nugraha list at
Tue Jun 3 09:17:52 CEST 2014

On Tue, Jun 3, 2014 at 6:56 AM, Robert Franklin <rcf34 at> wrote:
> On 2 Jun 2014, at 21:54, Adam Bishop <Adam.Bishop at JA.NET> wrote:

>> Your android issue looks a lot like this though, have you eliminated this as a cause:
> Reading that and the big thread it links to certainly all fits what we're seeing, although I'm not sure if where the EAP dialogue is aborting (prior to it saying the tunnel has been established) is where we would expect it to, if that was the the problem.
> I've tried the various suggestions on that thread but none have worked for me on the test phone.  This includes installing the WiFi Advanced Configuration Editor and adjusting the details of the configuration, but they do keep resetting to the broken ones people describe.
> So... the above problem seems likely, but I'm not sure why it's suddenly started occurring.  I think it's most likely changes to OpenSSL, perhaps as the reported SuSE version (0.9.8j) has some fixes from later versions backported, I believe.

If you think it's related to openssl version, have you had the chance
to create a test environment with older OS version (e.g. sles11sp2,
not updated) or opensuse 13.1?

It should help narrow down the bug. And since you say you use opensuse
build service, creating a new package for it should take less than 15


More information about the Freeradius-Users mailing list