Installation freeradius server failed

Muhammad Hasan muhhasan.1311 at
Mon Jun 9 10:18:22 CEST 2014

Hi Fajar,

thanks for your repply,
actually I am not familiar with freeradius,
I just following step that given from my friend.

My friend was tried eap-sim on freeradius server 2.2.0 before, and he was
the original step that he was gave to me is like this:
1. apt-get install dpkg-dev
2. apt-get build-dep freeradius
3. tar xvzf freeradius-server-2.2.0.tar.gz
4. edit eapsimlib.c (I was edit eapsimlib.c same as the step that I was
read in website)
5. etract debian file in freeradius-server-2.2.0 folder
type: debian/rules binary
6. install the packets:
a. dpkg -i libfreeradius2_2.2.0+git_i386.deb
b. dpkg -i freeradius_2.2.0+git_i386.deb
c. dpkg -i freeradius-common_2.2.0+git_i386.deb
d. dpkg -i freeradius-utils_2.2.0+git_i386.deb

but the step was succesfull until step 6 (b).
i got fail:
* checking FreeRADIUS daemon configuration ... [fail]
invoke-rc.d: initscript freeradius, action "restart" failed.
Processing triggers for ureadahead.

this is result when I type ​Freeradius -X
Unable to open file "/etc/freeradius/sql/mysql/ippool-dhc.conf": No such
file or directory
Errors reading or parsing /etc/feeradius/radius.confbut


and then I've tried on freeradius server 2.2.5
the different file on eapsimlib.c has been updated so I don't have to edit
I just next the following step.
but the result is still the same as before.

should I try the another method?
but I have no idea what's the another method :(

On Mon, Jun 9, 2014 at 3:00 PM, Fajar A. Nugraha <list at> wrote:

> On Mon, Jun 9, 2014 at 2:52 PM, Muhammad Hasan <muhhasan.1311 at>
> wrote:
>> Hi,
>> I want to ask something about installation freeradius server.
>> actually I want to try eap-sim on freeradius 2.2.5 in ubuntu sever 12.04
>> ​the step that I was tried are like these:
>> 1. apt-get install dpkg-dev
>> 2. apt-get build-dep freeradius
>> 3. tar xvzf freeradius-server-2.2.5.tar.gz
>> 4. install the packets:
>> a. dpkg -i libfreeradius2_2.2.5+git_i386.deb
>> b. dpkg -i freeradius-common_2.2.5+git_i386.deb
>> c. dpkg -i freeradius-utils_2.2.5+git_i386.deb
>> d. dpkg -i freeradius_2.2.5+git_i386.deb
> ... and where is the step where you actually compile the package? e.g.
> "dpkg-buildpackage -b"? Should be between step 3 and 4.
>>  I got failed when the step 4(d).
>> * Checking Freeradius daemon configuration... [fail]
>> invoke-rc.d: initscript freeradius, action "restart" failed
>> Precessing triggers for ureadahead...
>> this is result when i try freeradius -X command:
>> libssl version mismatch. built with: 1000105f linked: 1000100f
>> the problem is mismatch libssl? but I was trying to find the same version.
>> so what should I do?
> You probably download a prebuilt package (deb) belonging to another
> distro/version, not the one you actually compile. If you just want to use
> FR-2.2.5 on ubuntu, try
> --
> Fajar
> -
> List info/subscribe/unsubscribe? See

Best Regards,

Email : muhhasan.1311 at
CP : 085694394257
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list