Installation freeradius server failed

Fajar A. Nugraha list at
Mon Jun 9 10:43:19 CEST 2014

On Mon, Jun 9, 2014 at 3:18 PM, Muhammad Hasan <muhhasan.1311 at>

> Hi Fajar,
> thanks for your repply,
> actually I am not familiar with freeradius,
> I just following step that given from my friend.
> My friend was tried eap-sim on freeradius server 2.2.0 before, and he was
> successed.
> the original step that he was gave to me is like this:
> 1. apt-get install dpkg-dev
> 2. apt-get build-dep freeradius
> 3. tar xvzf freeradius-server-2.2.0.tar.gz
> 4. edit eapsimlib.c (I was edit eapsimlib.c same as the step that I was
> read in website)
> 5. etract debian file in freeradius-server-2.2.0 folder
> type: debian/rules binary
> 6. install the packets:
> a. dpkg -i libfreeradius2_2.2.0+git_i386.deb
> b. dpkg -i freeradius_2.2.0+git_i386.deb
> c. dpkg -i freeradius-common_2.2.0+git_i386.deb
> d. dpkg -i freeradius-utils_2.2.0+git_i386.deb

Your original mail doesn't mention the "debian/rules" part.

> but the step was succesfull until step 6 (b).
> i got fail:
> * checking FreeRADIUS daemon configuration ... [fail]
> invoke-rc.d: initscript freeradius, action "restart" failed.
> Processing triggers for ureadahead.
> this is result when I type ​Freeradius -X
> Unable to open file "/etc/freeradius/sql/mysql/ippool-dhc.conf": No such
> file or directory
> Errors reading or parsing /etc/feeradius/radius.confbut

are those typos? "dhc.conf" and "radius.confbut". Or are those what is
actually displayed?
In any case those usually means you've edited the config and broke it. The
default config should work fine.

> -------------------------------------------------
> and then I've tried on freeradius server 2.2.5
> the different file on eapsimlib.c has been updated so I don't have to edit
> again.
> I just next the following step.
> but the result is still the same as before.
> should I try the another method?
> but I have no idea what's the another method :(
Did you intentionally skip reading this part of my reply?

On Mon, Jun 9, 2014 at 3:00 PM, Fajar A. Nugraha <list at> wrote:

> You probably download a prebuilt package (deb) belonging to another
>> distro/version, not the one you actually compile. If you just want to use
>> FR-2.2.5 on ubuntu, try

That should qualify as "another method".

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list