Issue with DHCP with Wireless card

Hugh McLenaghan hughmcl at
Wed Mar 12 07:39:56 CET 2014


     I've been struggling getting the DHCP server to work.   I have the configuration correct.   The server starts fine, it listens on the port.   When a client sends a request, the request is received correctly.   it's then processed as expected, and it supposedly sends out the reply.   However I DO NOT see the reply on the interface when i do a tcpdump.    I've tried changing multiple settings including setting broadcast off/on, I've changed the IP address bindings and that doesn't help.

    I've also tried using different versions of freeradius, from 2.2.x  through 3.0.1 and 3.1.0 (the git repository).

    I know the wireless card will support it, because when i try using the regular ISC DHCPD daemon, it gets an IP address and I can see the request/reply packets.

    One thing I did notice though in the debug logs of freeradius, is when it supposedly sends the reply packet the source/from address is    however when ISC DHCPD sends it's response it comes from the IP address of the interface itself e.g.

    I've been fighting with this for days now.

     I've also tried using ISC-DHCP-relay server to relay the requests from the client WLAN0 interface directly to the DHCP server.   It sends the request to the server, which supposedly sends the reply back to it, however again, the response is never seen by the relay server.

    I'm wondering if somehow the dhcp part of the radius server isn't able to send the packets back, whether it's set up to use a gateway DHCP relay or not.

    Not sure how to troubleshoot this further.     Has anyone else had this issue?

     For my tests i've been using a raspberry Pi running raspian OS.    I'm going to try to do this on a regular VM tomorrow to see if it's related to the OS/hardware.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list