Issue with DHCP with Wireless card

Matthew Newton mcn4 at
Wed Mar 12 14:15:57 CET 2014


On Wed, Mar 12, 2014 at 01:39:56AM -0500, Hugh McLenaghan wrote:
> I've been struggling getting the DHCP server to work.   I have
> the configuration correct.

That's an interesting statement - there really isn't any sort of
"correct" at the moment :)

> The server starts fine, it listens on the port.   When a client
> sends a request, the request is received correctly.   it's then
> processed as expected, and it supposedly sends out the reply.
> However I DO NOT see the reply on the interface when i do a
> tcpdump.

OK, I had that working fine last night. Machine on network serving DHCP to
tablet (over wireless).

Can you post full debug logs from "radiusd -X" please.

> I've tried changing multiple settings including setting
> broadcast off/on, I've changed the IP address bindings and that
> doesn't help.

This worked here (you probably want eth0 not br0):

listen {
        ipaddr =
        port = 67
        type = dhcp
        interface = br0
        broadcast = yes

> I've also tried using different versions of freeradius, from
> 2.2.x  through 3.0.1 and 3.1.0 (the git repository).

Use 3.0.x HEAD. DHCP is new enough that you always want to be running the
latest code.

> I know the wireless card will support it, because when i try
> using the regular ISC DHCPD daemon, it gets an IP address and I
> can see the request/reply packets.
> One thing I did notice though in the debug logs of freeradius,
> is when it supposedly sends the reply packet the source/from
> address is    however when ISC DHCPD sends it's
> response it comes from the IP address of the interface itself
> e.g.

Where was it sending _to_? If, then it won't actually send anything,
and means that something has gone wrong.  I've got a patch that makes that
clearer in the debug, as I hit that as well.

> For my tests i've been using a raspberry Pi running raspian OS.
> I'm going to try to do this on a regular VM tomorrow to see if
> it's related to the OS/hardware.

Haven't tried it on my Pi, but I doubt that is the issue. System here is
Debian, so similar.



Matthew Newton, Ph.D. <mcn4 at>

Systems Specialist, Infrastructure Services,
I.T. Services, University of Leicester, Leicester LE1 7RH, United Kingdom

For IT help contact helpdesk extn. 2253, <ithelp at>

More information about the Freeradius-Users mailing list