NAS-Port always the same

Khapare Joshi khapare77 at
Mon May 26 16:37:11 CEST 2014

Thanks Alan,

How do I resolve my issue ?

a) we have a wireless access points are controlled by stupid cisco
b) I wanted to use radtump file for simualtaneous-user
    because WLcontroller always sends the NAS-Port=1 radutmp file is not
properly updated hence when I do radwho i always see the last users
is there anything that I can change in acct_users ?

On Mon, May 26, 2014 at 2:11 PM, Alan DeKok <aland at>wrote:

> Khapare Joshi wrote:
> > I am trying to use simualtaneous-use with radutmp file but cisco
> > controller is always sending the same port to all devices and logs
> > NAS-Port=1 for all devices in accounting detail file.
>   The NAS-Port is created by the NAS.
> > Can I not change that NAS-IP to actual wireless access point rather the
> > controller IP address ?
>   I wouldn't do that.
> > I tried changing /etc/raddb/acct_users file as :
> > NAS-Identifier == "mytestNAS", NAS-IP-Address :=
> > "%{Framed-IP-Address:-%{NAS-IP-Address}}"
>   Framed-IP-Address is for the end user.  It is *not* for the NAS.  You
> should never set NAS-Identifier to be Framed-IP-Address.
> > but I still get the NAS-Port=1 for all the device.
>   Because you're editing NAS-Identifier, not NAS-Port.
>   And you can't really change NAS-Port.  It's created by the NAS>
>   Alan DeKok.
> -
> List info/subscribe/unsubscribe? See
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list