compiling Freeradius v3 on Solaris 11

Sander Eerdekens sander.eerdekens at
Tue Feb 17 11:45:48 CET 2015


We are currently migrating to new servers for our freeradius setup,
And would like to take the opportunity to switch from freeradius v2 to freeradius v3 as well.
I am having some problems compiling freeradius v3 on Solaris 11, Though.
Until now we compiled Freeradius v2 on Solaris 10.

Now, we are trying to compile freeradius 3.0.6 on solaris 11.2 (SPARC).
I am using GCC 4.8.2 and gmake.

The issue I am bumping into is the same as described here:
(compiling Freeradius 3.0.3 at Solaris).
src/lib/udpfromto.c:251:6: error: 'struct msghdr' has no member named 'msg_control'

Is there anything I can do to help get this issue fixed?

Some other problems I ran into but managed to circumvent:
-       I have to use gmake, make gives an error on, line 33: Unexpected end of line seen
      Same issue as
-       I tried using solaris studio's cc, here I get stuck on "checking for talloc.h", even though I include -- with-talloc-include-dir with configure, cc does not know the -isystem it seems
      I can circumvent this issue by passing the dir in CCFLAGS in my environment variable
      Snippet from config.log:
      configure:7294: cc -c -g -mt -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -isystem /opt/csw/include/  conftest.c >&5
      cc: Warning: Option -ystem passed to ld, if ld is invoked, ignored otherwise
      Upon setting CFLAGS=' -L/opt/csw/lib -R/opt/csw/lib -I/opt/csw/include', this is resolved
-       I have tried compiling arran's Freeradius 3.0.7 RC0, but keep getting an error that my compiler must support C11,
      I am using Solaris Studio 12.4, whoch should support C11:
      Is my compiler broken?
      Relevant info from config.log:
      checking for the compiler flag to enable C11 support
      cc -c  -Werror -std=c11 conftest.c >&5
      configure: failed program was:
      | int
      | main ()
      | {
      |         struct foo {
      |           union {
      |             int a;
      |             int b;
      |           };
      |         } bar;
      |         return 0;
      |   ;
      |   return 0;
      | }

      If I try to compile the snippet itself I get a warning that the last return was not reached.
      Is my compiler broken, of what could be the issue here?
      With GCC I do not have this issue, but I end up in the problem that gcc does not know the -KPIC option,
      If I adjust the source to -fPIC, I end up in the same situation above with the udpfromto error.

My apologies for combining so much info in one mail, but I tried to be as thorough as I could in combining everything I have tried until now :)
Thank you very much in advance
Kind regards

Sander Eerdekens

More information about the Freeradius-Users mailing list