compiling Freeradius v3 on Solaris 11

Alan DeKok aland at
Tue Feb 17 13:36:35 CET 2015

On Feb 17, 2015, at 5:45 AM, Sander Eerdekens <sander.eerdekens at> wrote:
> Now, we are trying to compile freeradius 3.0.6 on solaris 11.2 (SPARC).
> I am using GCC 4.8.2 and gmake.

  That should work.

> The issue I am bumping into is the same as described here:
> (compiling Freeradius 3.0.3 at Solaris).
> src/lib/udpfromto.c:251:6: error: 'struct msghdr' has no member named 'msg_control'
> Is there anything I can do to help get this issue fixed?

  This should help:  ./configure —help

./configure ----with-udpfromto=no

> Some other problems I ran into but managed to circumvent:
> -       I have to use gmake, make gives an error on, line 33: Unexpected end of line seen

  Yes, the build requires GNU Make.

>      Same issue as
> -       I tried using solaris studio's cc, here I get stuck on "checking for talloc.h", even though I include -- with-talloc-include-dir with configure, cc does not know the -isystem it seems
>      I can circumvent this issue by passing the dir in CCFLAGS in my environment variable

  Well, the Solaris C compiler is garbage.

> -       I have tried compiling arran's Freeradius 3.0.7 RC0, but keep getting an error that my compiler must support C11,
>      I am using Solaris Studio 12.4, whoch should support C11:
>      Is my compiler broken?

  I’d say so.

>      If I try to compile the snippet itself I get a warning that the last return was not reached.

  It’s a warning.  Not an error.

  Alan DeKok.

More information about the Freeradius-Users mailing list