compiling Freeradius v3 on Solaris 11

Arran Cudbard-Bell a.cudbardb at
Tue Feb 17 15:17:44 CET 2015

> We are currently migrating to new servers for our freeradius setup,
> And would like to take the opportunity to switch from freeradius v2 to freeradius v3 as well.
> I am having some problems compiling freeradius v3 on Solaris 11, Though.
> Until now we compiled Freeradius v2 on Solaris 10.

You could take this opportunity to migrate away from solaris? :)

> Now, we are trying to compile freeradius 3.0.6 on solaris 11.2 (SPARC).

Mm that's going to be fun.

> I am using GCC 4.8.2 and gmake.
> The issue I am bumping into is the same as described here:
> (compiling Freeradius 3.0.3 at Solaris).
> src/lib/udpfromto.c:251:6: error: 'struct msghdr' has no member named 'msg_control'
> Is there anything I can do to help get this issue fixed?

From previous notes/rants, you need to define -D_XOPEN_SOURCE to match the C standard used.

> Some other problems I ran into but managed to circumvent:
> -       I have to use gmake, make gives an error on, line 33: Unexpected end of line seen
>      Same issue as
> -       I tried using solaris studio's cc, here I get stuck on "checking for talloc.h", even though I include -- with-talloc-include-dir with configure, cc does not know the -isystem it seems

Ok. Well, you're welcome to write a patch to check for -isystem to enable/disable it. Or use gcc/clang.
>      If I try to compile the snippet itself I get a warning that the last return was not reached.
>      Is my compiler broken, of what could be the issue here?

Hm. Fixed that. It's being extra picky.

>      With GCC I do not have this issue, but I end up in the problem that gcc does not know the -KPIC option,
>      If I adjust the source to -fPIC, I end up in the same situation above with the udpfromto error.

Solaris is a complete pain to build on. I managed to do with with the ldap module disabled.


Arran Cudbard-Bell <a.cudbardb at>
FreeRADIUS development team

FD31 3077 42EC 7FCD 32FE 5EE2 56CF 27F9 30A8 CAA2

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 872 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <>

More information about the Freeradius-Users mailing list