eapol_test from wpa_supplicat-2.4 fails with MPPE keys mismatch for TTLS:CHAP/MSCHAP/MSCHAPv2

Patrik Kis pkis at redhat.com
Wed Sep 9 17:23:09 CEST 2015


On Wed, 2015-09-09 at 09:26 -0400, Alan DeKok wrote:
> On Sep 9, 2015, at 6:15 AM, Patrik Kis <pkis at redhat.com> wrote:
> > I executed eapol_test from wpa_supplicat-2.4 (that is using TLS-1.2)
> > against freeradius-2.2.8 and the following cases are failing with "
> > [ttls] Tunneled challenge is incorrect":
> > EAP-TTLS/CHAP
> > EAP-TTLS/MSCHAP
> > EAP-TTLS/MSCHAPv2
> > Interestingly the same tests with eapol_test from wpa_supplicat-2.4
> > (that is using TLS-1.0) are fine.
> 
>   I've pushed a fix to all branches.

Thanks! That was fast!
I've tested it and it seems all cases are fixed. Thanks again!

> > I would be surprised if I was the first who tried to run these tests.
> 
>   You're the first one who noted it.
> 
>   Alan DeKok.
> 
> -
> List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html


-- 
Patrik Kis
QE BaseOS team
https://home.corp.redhat.com/user/pkis

Email: pkis at redhat.com
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purky┼łova 99/71, 612 45, Brno, Czech Republic



More information about the Freeradius-Users mailing list