return statement failure

Alan DeKok aland at
Thu Sep 22 16:23:36 CEST 2016

On Sep 21, 2016, at 10:03 PM, John Kristoff <jtk at> wrote:
> Using a packaged version 3.0.4 on a RedHat box

  If only RedHat would ship a version released in the last two years.  <sigh>

> I have in a
> sites-enabled/default config something that looks like this:
>  post-auth {
>          if (foo == barr {
>                  # do something
>                  ok = return
>          }

  That doesn't work, and was never intended to work.  No documentation ever said that it worked.

> If I remove the line with the 'return' in it, radiusd starts up just
> fine.  I must be missing something obvious?  This is adapted from a
> prior installation with 2.x, which apparently used to work.

  It worked by accident in 2.1, and 2.2.0.  Its has NOT worked in any version of the server since then.

> I'm a bit new to using FreeRADIUS and hopefully only a gentle whack
> with the clue bat is needed.  Thanks for the clue in advance.

$ man unlang

  There's a "return" statement.

	if (ok) {

  Alan DeKok.

More information about the Freeradius-Users mailing list