Shared key mismatch

Alan DeKok aland at
Mon Apr 3 20:58:01 CEST 2017

> On Apr 3, 2017, at 2:24 PM, Ondřej Lauer <Ondrej.Lauer at> wrote:
> I run it in debug mode, have tried radtest to send some request to me to 
> localhost - but it still says "Secret key mismatch" and I have no idea where
> to look when I want to debug what is FreeRADIUS comparing so I can have 
> better idea what might be wrong. Would core dump help me ? 

  I suggested that you read the debug output.  Not just 1-2 lines, but ALL OF IT.

  I also said to look at the "client" definition.  You will see the clients and secrets being printed out.

  I also suggest that you ask PacketFence how their software works.

  When you use FreeRADIUS all by itself, it works.  So if it doesn't work... it's not the fault of FreeRADIUS.

  Now, stop asking the same question over and over, and go follow instructions.  That's the only thing which will solve the problem.

  Alan DeKok.

More information about the Freeradius-Users mailing list