understanding NAS and accounting packets

Alan DeKok aland at deployingradius.com
Tue Jun 20 22:47:20 CEST 2017

On Jun 20, 2017, at 4:36 PM, Saurabh Shandilya <saurabhshandilya.1991 at gmail.com> wrote:
> I have tried to go through a few times over the online present materials
> for freeradius but still I am not able to wrap my head around NAS.

  Read the FreeRADIUS technical guide at:


> Is my d-link 850l is NAS?


> There are no accounting packets, I checked it with radsniff.

  Then the NAS isn't sending accounting packets.

> I am attaching a very big output response from my free-radius output.
> Initial few attempts are done while I tried connecting from my android
> phone to wireless AP with wrong credentials.  Line number 1890 is when I
> sent request with correct credentials.
> Also, attaching my default file under sites-enabled/.

  Please don't include that.  The debug output is all we need.

> Let me know if any other outputs or logs are required.

  You need to fix the NAS so that it sends accounting packets.

  Alan DeKok.

More information about the Freeradius-Users mailing list