Problem with shared secret on H3C WX5004

Igor Sousa igorvolt at
Tue Oct 10 03:54:48 CEST 2017

Hello Alan,

I've identified the problem's cause. When I tried to configure by HTTP
interface, I've seen that the controller doesn't correctly store the shared
secret. I saw it because I'd tried to configure it from CLI and it's worked.

Sorry about this stupid question, I understand this controller is obsolete
and it would be hard for anyone to have a similar device and expertise
about the same issue. While there is life, there is hope.

Thanks for your help.

PS: I want to thank you and everyone that maintain this list, you help a
lot of people for free. It's wonderfull. It's my sincerely feelings.


Igor Sousa

2017-10-09 19:02 GMT-03:00 Alan DeKok <aland at>:

> On Oct 9, 2017, at 11:46 AM, Igor Sousa <igorvolt at> wrote:
> >
> >
> > I've already radius configuration in WX5004 that pointing to a freeradius
> > server 2.x. Aiming to test freeradius 3.0.15, I've configured another
> > radius configuration and pointing to freeradius server 3.x, but when
> > Access-Request arrives to freeradius 3.x, freeradius drops because shered
> > secret is incorrect. Thus, I have two questions:
> >
> >   1. Is there a method to check shared secret in message sent to
> >   freeradius?
>   No.  It's impossible.
> >   2. Someone have similar problem with this controller (H3C WX5004)
>   No.
>   If v3 drops the packet because the shared secret is incorrect, then you
> need to re-enter the shared secret on both systems.
>   There's no magic here.  There's nothing special in v3 versus v2.  Both
> implement RADIUS, and do it correctly.  If v3 says that the shared secret
> is incorrect, it's because the shared secret is incorrect.
>   Alan DeKok.
> -
> List info/subscribe/unsubscribe? See
> list/users.html

More information about the Freeradius-Users mailing list