eap-fast: using eap-fast-mschapv2 in anonymous tunnel

Alan DeKok aland at deployingradius.com
Sat Sep 23 17:54:28 CEST 2017

On Sep 23, 2017, at 10:16 AM, Isaac Boukris <iboukris at gmail.com> wrote:
> I'm still seeing failures, note that it's running on 32bit arch, which
> had led into strange bugs in the past.

  Ah... we do most of the testing on 64-bit, but it *should* work on 32-bit systems.

> In server authenticated only flow (phase1="fast_provisioning=2") i get
> this consistently:
> phttps://filebin.ca/3bNwuiCQ3ddm
> In unauthenticated flow (phase1="fast_provisioning=1"), the first
> request causes the server to exit with:
> https://filebin.ca/3bNzY0BK89xv

  That looks like the same error.  I'd need to see the full gdb output for more.

> But that first request does provision the pac file, and so the
> subsequent request succeeds using the pac.
> However, when I run eapol_test repeatedly a few times, the server
> exits again with:
> https://filebin.ca/3bO0B1s5uUHY

  That assertion is just weird.  It's asserting that time only goes forward, which it should...

  What OS are you using?

  Alan DeKok.

More information about the Freeradius-Users mailing list