eap-fast: using eap-fast-mschapv2 in anonymous tunnel

Isaac Boukris iboukris at gmail.com
Sat Sep 23 18:41:49 CEST 2017

On Sat, Sep 23, 2017 at 6:54 PM, Alan DeKok <aland at deployingradius.com> wrote:
> On Sep 23, 2017, at 10:16 AM, Isaac Boukris <iboukris at gmail.com> wrote:
>> In server authenticated only flow (phase1="fast_provisioning=2") i get
>> this consistently:
>> phttps://filebin.ca/3bNwuiCQ3ddm
>> In unauthenticated flow (phase1="fast_provisioning=1"), the first
>> request causes the server to exit with:
>> https://filebin.ca/3bNzY0BK89xv
>   That looks like the same error.  I'd need to see the full gdb output for more.

Log with gdb backtrace at:

>> But that first request does provision the pac file, and so the
>> subsequent request succeeds using the pac.
>> However, when I run eapol_test repeatedly a few times, the server
>> exits again with:
>> https://filebin.ca/3bO0B1s5uUHY
>   That assertion is just weird.  It's asserting that time only goes forward, which it should...
>   What OS are you using?

Sorry, I haven't looked much into the error itself, I'll try to.
I'm testing on a virtual machine, running Linux fedora, with libkqueue
built from git source.

$ uname -a
Linux fedora 4.11.12-100.fc24.i686+PAE #1 SMP Fri Jul 21 17:51:58 UTC
2017 i686 i686 i386 GNU/Linux
$ openssl version
OpenSSL 1.0.2k-fips  26 Jan 2017


More information about the Freeradius-Users mailing list