Freeradius crash please help

8zero2 operations 8zero2ops at
Tue Dec 11 06:27:20 CET 2018

Hi Thanks a lot man for taking time to reply, really appreciate it.

I removed the exec + COA , Now i am printing the users to a file using
exec. and then a background script sends COAs.
- Spawning less threads kind of solves the problem.
I see some errors "Timeout waiting for child" for an exec(shell) script
which basically prints (time - 900 seconds). I tried to switch with a perl
script(exec), but it slows down authentications a lot.
I know this doesnt relate you but
this is the script :

date  --date="$1 seconds" '+%Y-%m-%d %H:%M:%S'

$1 is the argument given
A question regarding this : Can I do something about this?

Mail: at
Twitter: @8zero2_in

On Mon, Dec 10, 2018 at 9:51 PM Alan DeKok <aland at>

> > On Dec 10, 2018, at 7:25 AM, 8zero2 operations <8zero2ops at>
> wrote:
> >
> > Please help man, I have tried different OS different versions but this
> > crash problem doesnt leave, this is 3.0.x.
>   If this is still the "exec program + COA" problem, then we don't have a
> fix.  I have been unable to reproduce it here, and I haven't had time to
> look at it in more detail.
>   About the only thing I can suggest is to run the server as:
>         radiusd -xxxx ... > log.txt
>   The log.txt file will be large, and 99% of it won't be relevant.  But it
> *should* at some point print out an error.  e.g. "X is parented by Y but it
> should be parented by Z"
>   That error, and the subsequent lines are useful.  Everything before that
> is not important.
>   Alan DeKok.
> -
> List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list