Subject: First time run failure - magic number mismatch

Jiuyu Sun sunjiuyu at
Fri Jul 19 22:58:03 CEST 2019

Thanks Alan for the quick response!

I've tried remove the freeradius first:

sudo apt-get remove freeradius
sudo apt-get remove --auto-remove freeradius
sudo apt-get purge freeradius
sudo apt-get purge --auto-remove freeradius

And also,
dpkg -l | grep -i radius
dpkg -P [all the output from above]

Then it still gave me the same error after I install from source.

Is there anything I miss on uninstalling the old version? Thank you!

On Fri, Jul 19, 2019 at 1:26 PM Alan DeKok <aland at>

> On Jul 19, 2019, at 4:22 PM, Jiuyu Sun <sunjiuyu at> wrote:
> > I am trying to install Freeradius from source on a Linux machine. When I
> > run radiusd -X, I got the following error:
> >
> > $ sudo radiusd -X
> > radiusd: Application and libfreeradius-radius magic number (version)
> > mismatch.  application: 30020c library: 30020f
>   You have installed two different versions of the server.  Don't do that.
>   Alan DeKok.
> -
> List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list