Unable to create control socket

email.me at kevp.com email.me at kevp.com
Sun Apr 26 15:31:57 CEST 2020

Hi all,


Can anyone please help me get the control socket for radmin working on


I've built FreeRADIUS v3.0.21 debs from source and install the debs on
Ubuntu 18.04.

I then created some ssl certs and the default config starts up ok.


I then add a symlink to turn on the control-socket and sudo freeradius -X
gives the error:


Failed creating control socket "/var/run/freeradius/freeradius.sock": Failed
creating control socket directory: Permission denied


I know the service startup has comments about the directory creation not
working on Ubuntu Bionic (18.04).

So I've tried creating /usr/lib/tmpfiles.d/freeradius.conf containing: 'd
/var/run/freeradius 0755 freerad freerad -'

Ran sudo systemd-tmpfiles --create but no /var/run/freeradius

Rebooted and no /var/run/freeradius

sudo freeradius -X gives same error (as above).


Anyone know how to get the control-socket to start correctly on Bionic?


I've also tried on Ubuntu 16.04 and get the same issue, but I rather fix on
18.04 if poss.


Many thanks all,





More information about the Freeradius-Users mailing list