Unable to create control socket

Matthew Newton mcn at freeradius.org
Sun Apr 26 17:16:52 CEST 2020

On 26/04/2020 14:31, email.me at kevp.com wrote:
> I then add a symlink to turn on the control-socket and sudo freeradius -X
> gives the error:

Which symlink? sites-enabled, or something else?

> Failed creating control socket "/var/run/freeradius/freeradius.sock": Failed
> creating control socket directory: Permission denied
> I know the service startup has comments about the directory creation not
> working on Ubuntu Bionic (18.04).

Yes, but the lines above it do work. Or at least they did.

> So I've tried creating /usr/lib/tmpfiles.d/freeradius.conf containing: 'd
> /var/run/freeradius 0755 freerad freerad -'
> Ran sudo systemd-tmpfiles --create but no /var/run/freeradius

That shouldn't be necessary.

> Anyone know how to get the control-socket to start correctly on Bionic?

I'm pretty sure it was working, we went through a load of testing to get 
unit file settings that worked on multiple systems, hence the comments 
and (essentially) duplicated solution. Maybe Ubuntu changed something.


More information about the Freeradius-Users mailing list