Problem with MySQL and Accouting-On record

Alan DeKok aland at
Tue Nov 17 15:01:50 CET 2020

On Nov 17, 2020, at 8:10 AM, Ángel L. Mateo <amateo at> wrote:
> 	Althought this workaround worked in my test environment, I'm still having problems in production.

  Then something's different in the configuration between the two systems.

> 	I can't run productionn with "freeradius -X", so I'm trying to get debug log with raddebug. My problem is that when I run "raddebug -c 'Acct-Status-Type == Accouting-On' I'm getting the debug from the packet when it is received by freeradius, but I'm not getting the info when it is processed by the buffered-sql virtual server.
> 	I'm looking for a way to debug only this virtual server, but I can't find it. Is there a way to do this? to debug just the buffered-sql virtual server?

  Hmm... the detail file reader injects packets into the server core using the same system as the other listeners.  I'm not sure why it wouldn't print out those packets.

  Have you checked that those packets are in the detail file?

  Alan DeKok.

More information about the Freeradius-Users mailing list