Alan DeKok aland at
Fri Apr 26 12:43:14 CEST 2019

On Apr 26, 2019, at 3:06 AM, Sudheer Satyanarayana <sudheer at> wrote:
> I am trying to use the Simultaneous-Use feature of FreeRADIUS.
> I have some questions regarding
> I am using SQL and I have set Simultaneous-Use to 1 with the := operator. I can see this in debug output.

  That's good.

> Is the implementation notes regarding radutmp valid for SQL too?

  Which notes?

> I have verified that simul_count_query and simul_verify_query are syntactically correct. When I execute them manually, I see some SQL results in PostgreSQL console.
> I tried to run radcheck like this:
> checkrad -d other 0 testuser01 'ACA31EB30AD1-70BBE9363CBC-5CC2A65E-8DAD3'
> Returning 1 (double detected)

  Because it *always* returns "1" for type "other".

> I am using Aruba NAS. I do not know what NAS-Type to use. I tried 'other' and it doesn't seem to have any effect.
> Should I be looking at getting checkrad to work first before doing anything else? If so, any tips to get this to work with Aruba NAS would be appreciated.
> At the moment, FreeRADIUS allows login from two devices at the same time for the same user. I am not sure what approach to take here. Some guidance would be appreciated.

  Simultaneous-Use only works if the NAS sends accounting packets.  This is made clear in section 5 of the document you read.

  So is the NAS sending accounting packets?

  Alan DeKok.

More information about the Freeradius-Users mailing list