They primary key should be a synthetic field, and not something derived directly from the packet. Calling it 'acctuniqueid' is awkward, maybe renaming it to 'radiuskey'?
It can then be used in the SQL queries as %{Acct-Unique-ID:-%{Acct-Session-id}}, which should be safe for all configuration.
NOP, the default definition of the acctuniqueid attribute is correct. acct_unique { key = "User-Name, Acct-Session-Id, NAS-IP-Address, Client-IP-Address, NAS-Port" } It is more possible that a user connect and disconnect several times in a same session. I think it is task of the NAS to assign a unique session id to a user. With acct_unique specification freeradius builds acctuniqueid attribute. This is my reason for the change. Do you agree??? _________________________________________________________________ Grandes éxitos, superhéroes, imitaciones, cine y TV... http://es.msn.kiwee.com/ Lo mejor para tu móvil.