Matthew Newton wrote:=
As a suggestion, it might be better to introduce new unambiguous syntax for both cases, and then set the existing syntax to the same as v2 (for least surprises) and deprecate it? "if (noop) {..}" has always confused me as to what status it's actually checking...
Yeah. New syntax is always better.
How about
if (rc:module == noop) { ... }
to check the latest module return code, and
if (rc:group == reject) { ... }
"rc" is a little unclear.
to check the current code in the group? Alternatives could be "return:module" or "rc:section" or even "rc:last" and "rc:return" for the last module that set it, and the current value that will be returned from the section.
Maybe.
Using control attributes might be better as Phil said to avoid the virtual attribute stuff - just control:RC-Module or control:RC-Group would make it unabmiguous.
I just want to avoid updating / creating a new attribute for every module call. It's expensive and annoying. Alan DeKok.