On Wed, Oct 16, 2013 at 10:42:57AM -0400, Alan DeKok wrote:
So if you must do this, please make it a *short to type* and *real* control: attribute - control:RC perhaps?
As a suggestion, it might be better to introduce new unambiguous syntax for both cases, and then set the existing syntax to the same as v2 (for least surprises) and deprecate it? "if (noop) {..}" has always confused me as to what status it's actually checking... How about if (rc:module == noop) { ... } to check the latest module return code, and if (rc:group == reject) { ... } to check the current code in the group? Alternatives could be "return:module" or "rc:section" or even "rc:last" and "rc:return" for the last module that set it, and the current value that will be returned from the section. Using control attributes might be better as Phil said to avoid the virtual attribute stuff - just control:RC-Module or control:RC-Group would make it unabmiguous. Cheers, Matthew -- Matthew Newton, Ph.D. <mcn4@le.ac.uk> Systems Specialist, Infrastructure Services, I.T. Services, University of Leicester, Leicester LE1 7RH, United Kingdom For IT help contact helpdesk extn. 2253, <ithelp@le.ac.uk>