On 16 Oct 2013, at 17:38, Matthew Newton <mcn4@leicester.ac.uk> wrote:
On Wed, Oct 16, 2013 at 05:19:14PM +0100, Arran Cudbard-Bell wrote:
On 16 Oct 2013, at 17:05, Alan DeKok <aland@deployingradius.com> wrote:
"rc" is a little unclear.
It's also not a list.
Yeah, whatever - it was the first thing that came to mind as an example :-)
[insert random discussion about how best to do it here ->]
No more magic, no more magic.
to check the current code in the group? Alternatives could be "return:module" or "rc:section" or even "rc:last" and "rc:return" for the last module that set it, and the current value that will be returned from the section.
Maybe.
I strongly disagree with this. We should not invent new syntax just for this case. It should be a paircmp or an xlat.
It's already a different syntax in the current system.
Yes. I know. Apparently absolute consistency is a bad thing. Mmm.
But an xlat does sound like a cleaner way to do it. (As long as the ambiguity is gone.)
Well it's a bit icky. paircmp is more efficient in some cases, that's why I suggested both. Arran Cudbard-Bell <a.cudbardb@freeradius.org> FreeRADIUS Development Team