[rad] Re: SOLVED Re: pseudo-newbie exec scripts and session-time

Charles Gregory cgregory at hwcn.org
Sat Jun 13 06:01:07 CEST 2009

On Fri, 12 Jun 2009, Ivan Kalik wrote:
> Nothing to give. You already have it in scripts/exec-program-wait.

I do not have a directory named 'scripts'. And the only reference to
'exec-program-wait' is in the comments of 'experimental.conf' as something 
that a 'perl' rlm can 'replace'. I'm really thinking that CentOS screwed 
up some documentation....

>>          #  Attribute-Name = `%{exec:/path/to/program args}`
>> Notice the complete lack of instruction as to WHERE I would use that
>> syntax....
> Well, you don't have to be a genius to figure out where does something
> like Attribute = value goes.

Well, whatever I needed to be, I'm not. (weak grin)
Does executable syntax belong in the users file?
Or is there some other place in the radiusd.conf that is obvious
to you but not to me?

> ... simply listing module name in the configuration (like you have
> "discovered") also works - just like with any other module.

(nod) As I said, something *else* was preventing it from functioning
the first time I tried it... (sigh)

> Go and read the example script included with the server and then come 
> back and eat your words.

WHAT ##### "EXAMPLE SCRIPT"? And if someone finally tells me where it 
is (in vers. 1.x) then why should I eat my words for getting the thing I 
kept ASKING for?

You know, I won't call this whole thing *your* fault if it turns out that 
CentOS put in a crippled installation missing examples....

But it ain't mine either....

- Charles

More information about the Freeradius-Users mailing list