[rad] Re: SOLVED Re: pseudo-newbie exec scripts and session-time

Charles Gregory cgregory at hwcn.org
Sun Jun 14 14:56:23 CEST 2009

On Sun, 14 Jun 2009, Alan DeKok wrote:
> Charles Gregory wrote:
>> No, I'm offended that you can say things like you have "NO IDEA" when
>> clearly anyone who read my first post would know what I was asking.
>  Yes, but you were given 5-6 options for solving the problem.

Five or six huh? Quote them. Paraphrase them. And don't just lamely say 
"check the archives" because I did that when I double-checked that you 
'had no idea'. I've been up and down this thread a few times now. And 
there is NO posting with clear code like the one I posted in my 'solved' 
post.... Just pedantic demands I upgrade, and vague "look at the docs".

OH, and as a side note, I just double-checked the 'users' file and the 
users man page, and NEITHER of them contain the word 'exec' ANYWHERE in 
any context or usage. So WHERE exactly was I supposed to find the 
instructions to do what I wanted to do? Yes, yes, version 2.x.... But 
given my constraints, 'read the docs' was utterly useless.

I await your QUOTE of '5 or 6' options. I'll presume one of them was to 
upgrade to 2.x so you can skip that one....

>  Is a result, I have *no* idea what you were trying to do.

Oh, so now it's a word game. You knew what I was trying to do but confused 
by the manner in which I was trying to do it? Didn't that clue in the big 
expert that someone had badly misinterpreted the documentation and was 
trying to do something WRONG and should have been told how to do it 
right? Did it occur to you that at the start of this thread I had never 
heard of 'wait program exec'? It's not mentioned in my users file docs.
Was that ever in version 1.x? I wouldn't know.

> If you were trying to solve the problem you *claimed*, the existing 
> documentation and examples should have been sufficient.

THEY WEREN'T. That's the whole point. I was asking for MORE. Examples.
A working script and config that did what I wanted. If someone asked this 
question now, I would post my half dozen lines from my config, saying, 
this is one way to do it and be DONE.

> Instead, it was clear that you were trying to do nearly everything 
> *except* follow the suggestions on this list, or the examples and 
> documentation shipped with the server.

WHICH examples? NAME THEM. I only found ONE after John (?) pointed out I 
was missing a file. And even that one uses a method that is described as 
deprecated in the code.

Look, you want to dance this dance, I'm game. But you are going to have to 
face the fact that (1) I'M NEW AT THIS, so don't presume I have that 
benefit of context. (2) The documentation in 1.x was obviously 
inadequate, so saying 'look in the docs' is utterly useless unless somehow 
you expected me to read every single doc file in HOPES of finding the one 
file that describes exec.

Really, why weren't the docs in the radiusd.conf or users documentation?
You say you wrote this stuff. How could you leave something out (and then 
act like it was always there and I failed to read it)?

- C

More information about the Freeradius-Users mailing list