Include directive for separate ippool configs not working

Alan DeKok aland at
Fri Jul 1 19:44:30 CEST 2011

Tom De Vylder wrote:
> I'd like to integrate freeradius into a config management framework.
> In order for this to work with multiple ippool instances I've decided to create a ippool.d/ directory containing several config files.

  Those files are... ?  That information might help.

> Loading the config files itself is not a problem, however placement of the include statement is.

  Uh... no.  The $INCLUDE statement includes the files or directory you
name, in the place of the $INCLUDE statement.

> I've tried to put the following line in several places: 
> $INCLUDE /etc/freeradius/ippool.d/
> E.g.: 
> - At the end of modules {},
> - Below a working ippool main_pool {}, which resides inside modules {}
> - Inside instantiate {}
> - authorize {)
> - ...
> Nothing seems to work.

  Wonderful.  You didn't follow the existing examples or documentation,
and you tried a bunch of random things in the hope that they might work.

  Each module configuration goes into the "modules" section.  This is
documented, and numerous examples are given.  There are even examples of
configuring multiple instances of a module.  There are even examples of
*using* multiple instances of a module.

  So...  Are you including the module configuration in the correct place?

  Have you configured multiple instances of the module correctly?

  Are you *using* each instance of the module?

  Alan DeKok.

More information about the Freeradius-Users mailing list