Freeradius 2.0.5 simple configuration fail

ael.gain at ael.gain at
Wed Jul 6 13:53:49 CEST 2011

Thank you for your quick answer.
I just change to peap in the eap.conf but i still have the same error.
Maybe i'll send an email to the maintener of the paquet.
I also tried to compile the last version of FreeRadius from sources but i was running into a lot of bugs...

----- Mail Original -----
De: "Alan Buxey" <A.L.M.Buxey at>
À: "FreeRadius users mailing list" <freeradius-users at>
Envoyé: Mercredi 6 Juillet 2011 13h22:55 GMT +01:00 Amsterdam / Berlin / Berne / Rome / Stockholm / Vienne
Objet: Re: Freeradius 2.0.5 simple configuration fail


> I'm currently trying to set a Freeradius 2.0.5 on a synology NAS which I installed via ipkg. 
> I would like to authenticate the wifi users throught a netgear WG103 '802.1x enabled'.
> So i've just modified the users file to add a 'rad' user :
> "rad Cleartext-Password := "rad""
> And added in clients.conf :
> client {
>         secret          = ap_pass
>         shortname       = ap  
> }
> I configured the ap according to these settings.
> Everything works fine when using radtest, but when trying to authenticate with the ap, i get the debug output that I put in attached file.

firstly, 2.0.5 is hideously old - and very very buggy.  2.1.x should be
a minimum. can you get your package folk to upgrade their FreeRADIUS package?

secondly, change your default eap type in the eap.conf to peap - you seem to have md5 
which means a lot of NAK junk - this streamlines EAP.   you cant do md5 with wireless.

> I suppose the problem comes from :
> "auth: No authenticate method (Auth-Type) configuration found for the request: Rejecting the user
> auth: Failed to validate the user."

from a quick look i'd say things should be okay - make the EAP change and
see if the AP plays nicely

List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list